Turbo Dodge Forums banner

521 - 540 of 567 Posts

·
Registered
Joined
·
468 Posts
Any time!!

My labels seem to be falling off as they probably don't stick to "cloth" very well.

It's a wonder they're still there.

Thanks
Randy
Any way you could post a pic of the orientation of the labels? Not trying to do a concours restore but don't want to slop it together either.

So when's the famous Stampede happening? I hear the whole of Calgary shuts down for it!

Thanks & take care!
 

·
Registered
Joined
·
12 Posts
So, I took off the EGR valve and sprayed it out with carb cleaner. It started up and ran. 10 minutes later I turned it off, then 20 minutes later I turned it back on, and it died on idle (this is the same problem it had before and why I cleaned the EGR). Does anyone know what is wrong? Or know a quick fix? Please let me know.
 

·
Registered
Joined
·
468 Posts
So, I took off the EGR valve and sprayed it out with carb cleaner. It started up and ran. 10 minutes later I turned it off, then 20 minutes later I turned it back on, and it died on idle (this is the same problem it had before and why I cleaned the EGR). Does anyone know what is wrong? Or know a quick fix? Please let me know.
Try disconnecting the vacuum hose from the EGR and plug the hose. If the idle is unsatisfactory replace the EGR valve (per the FSM). However, the FSM states that after replacement and the idle still is unsatisfactory then you need to check the vacuum on the "ported signal tap". If greater than 1" Hg then check your idle set. If less then check the carb linkage & throttle blades for binding.

Are the vacuum lines in good condition?
Is the carb "clean", no deposits especially in the slotted port in the throttle bore? Vacuum passageways not clogged?

See what happens when you disconnect the vacuum hose from the EGR. If the idle smooths out, it's most likely the EGR needs replacing or could be just clogged passageways...
 

·
Registered
Joined
·
12 Posts
Just did that, didn't help, but many of the hoses have really shoddy connections, rag ties, electrical tape, loose hose clamps, no hose clamps, so I wouldn't be surprised if there is a leak somewhere. The carb is clean though, so is the air filter.
 

·
Registered
Joined
·
468 Posts
Get some new vacuum line and replace them one by one. The new lines shouldn't need clamps. You're probably getting some leaks which is affecting the idle & performance of the carb. If nothing else cut the end of the line off & reattach. This is assuming the remainder of the line is in good condition. Carbs are real finnicky about their vacuum...
Any Auto Parts store has vacuum line. Figure out the size and about how many feet you'll need and buy it "in bulk" from them by the foot.
Once you rule out the vacuum issues then the rest will be a piece of cake!
 

·
Registered
Joined
·
468 Posts
Ah, another thing: make sure the carb is tightened down good on the isolator & intake manifold. Any leakage there will affect the whole vacuum system...
 

·
Premium Member
Joined
·
2,479 Posts
Well the mystery continues. Perhaps the decals weren't a required item on vehicles. Maybe Chrysler had a "dress-up package" option for the back that included the carpet & tray so no decals to waste money. I did notice that the bottom brackets for the tray have no holes drilled for the tray's mounting screws.



Ha! I've got a rare Rampage! Only one with jack instruction decals! :smile2:
On the standard Rampages and Scamps, the Jack stickers were on the inside of the carpeted cover for the Jack. Never seen them where your picture shows them.

Sent from my LG-H900 using Tapatalk
 

·
Registered
Joined
·
468 Posts
On the standard Rampages and Scamps, the Jack stickers were on the inside of the carpeted cover for the Jack. Never seen them where your picture shows them.

Sent from my LG-H900 using Tapatalk
Well there you are 83scamp!

I've been in a tizzy trying to figure out (What the Hell Bobby!) what the deal was with my labels.

The things that occur to 36 year old cars...
 

·
Registered
Joined
·
438 Posts
John meet Greg, Greg meet John. Greg is our Celebrity Scamp Trucklet Owner John. Look at his Avitar Pic then look at the Scamp on the top margin when you first click on the Turbo Dodge Site. I consider Greg among My Good Friends & Car-Buds on the planet even tho' we now live 1/2 continent apart. We've shaken hands ah few times over the last 1/2 dozen years or so. Both he and I have now made our Scamps go way faster then how Mother Mopar intended them to be when she brought them to life RIGHT GREG? He prefers to grab gears and I'm lazy, I prefer to let my left foot rest lol, Jer
 

·
Premium Member
Joined
·
2,479 Posts
Well there you are 83scamp!



I've been in a tizzy trying to figure out (What the Hell Bobby!) what the deal was with my labels.



The things that occur to 36 year old cars...
Yeah, I'm still alive and kicking. Don't get on the forums as much anymore.

Got the Scamp out for the first time this year last Saturday. Local place had a cars and Coffee event. A lot of nice cars, but only one Scamp. got a lot of attention and questions.

It felt really good to get it out again. It's just as fast as I remember. What a rush!!! Going turbo was the best thing I ever did for this truck. Wasted way too many years with the carbed motor.

Sent from my LG-H900 using Tapatalk
 

·
Registered
Joined
·
468 Posts
Yeah, I'm still alive and kicking. Don't get on the forums as much anymore.

Got the Scamp out for the first time this year last Saturday. Local place had a cars and Coffee event. A lot of nice cars, but only one Scamp. got a lot of attention and questions.

It felt really good to get it out again. It's just as fast as I remember. What a rush!!! Going turbo was the best thing I ever did for this truck. Wasted way too many years with the carbed motor.

Sent from my LG-H900 using Tapatalk
Nice to met ya Greg!

Checked out your pics. Very nice indeed yes sire-bob!! :grin2:

I know going turbo would probably make the trucklet more enjoyable to drive but I'm going for a stock restore. Won't be a concours one as I'm doing it in my gravel driveway. Wish I had a garage but my shed has my DD and my '80 Mitsu tractor with a 2 cylinder diesel. Engine is done but waiting on a new AT shift cable as oem one is stretched out where the shifter doesn't line up with the marks.

Next is floor pans/interiors then the body and paint...

I'll be posting more pics when I'm happy with it!:laugh2:
 

·
Registered
Joined
·
438 Posts
When I was hauling a 440 back from Lansing, Mi. in my lil' scamper after a re-build at Muscle Motors up their and almost got EATEN BY A KENWORTH GETTING BACK ON THE FREE-WAY to bring it home. The decision was then made for me about more better acceleration. I know Mother rated the Trucklets @ 1152lb haul weight, But they don't like 750lbs of 440 on their back with a 2.2L carburetor hoffin' and puffin'. Way better with a 2.5L TII don't matter if you grabbin' gears or just stomp the peddle 'n go, lol. Jer
 

·
Premium Member
Joined
·
2,479 Posts
The worst that I'd be hauling would be some bags of fertilizer or some babes back to house! >:)

Decisions, decisions...
About the only thing the Scamp hauls anymore is @ss... and it does that very well.... I do haul a few things in it, but after recently purchasing a Dakota, I use it for all my truck duty instead of the Scamp.

Sent from my LG-H900 using Tapatalk
 

·
Registered
Joined
·
438 Posts
Decisions between Fertilizer and Babes John? Somebody take this poor mans temperature PAHLEEZ, lol Greg. You still have the pics of my Lil' ScamPage? If so send those to John (if you'd be so kind) along with some of that Beauty of yours and maybe we can get John thinkin' outside the box ah bit. I'd send 'um myself but you know how limited my 'Puter skills are? :grin2:Jer
 

·
Registered
Joined
·
468 Posts
Decisions between Fertilizer and Babes John? Somebody take this poor mans temperature PAHLEEZ, lol Greg. You still have the pics of my Lil' ScamPage? If so send those to John along with some of that Beauty of yours and maybe we can get John thinkin' outside the box ah bit, Jer
Hah! The problem is my Rampage is my 3rd wife. She costs a lot and I'm afraid how jealous she may be. She'll leave me stranded on the side of the road if I don't behave! :crying:
 

·
Registered
Joined
·
2,211 Posts
John, nice work!

Any chance you could take a couple more pics please??

I'm replacing my 4 headlight nose with a 2 and am finding the differences.

The plate or bracket that goes from the nose to the rad support with the hood catch.

Mine doesnt fit and I'd like to see what the right one looks like.

Also 2 little brackets on each side of the rad that also go to the nose.

What do you mean about the hood pins??

LOL: Figured it out!!

Thanks
Randy
 

·
Registered
Joined
·
468 Posts
John, nice work!

Any chance you could take a couple more pics please??

I'm replacing my 4 headlight nose with a 2 and am finding the differences.

The plate or bracket that goes from the nose to the rad support with the hood catch.

Mine doesnt fit and I'd like to see what the right one looks like.

Also 2 little brackets on each side of the rad that also go to the nose.

What do you mean about the hood pins??

LOL: Figured it out!!

Thanks
Randy
Thanks very much! Been working on it for 20 months now. No garage, car under a tarp in my gravel driveway (Why do we park in a driveway but drive in a Parkway?) so it's been slow progress with the weather. I'm actually hoping to get it out on the road this week...

Yeah, I'll take some pics for you. Raining today but suppose to be sunny tomorrow...
 
521 - 540 of 567 Posts
Top