Turbo Dodge Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
182 Posts
Discussion Starter · #1 ·
Okay the basics 2.2,slidercam, t2lower end, 2peice intake ,90 lebaron gtc , factory2.5 lebaron computer,injectors,boost just on the edge of over boost .
it is also converted to intercooled t2 stuff


I don't know were i am as far as being okay with fuel I get nine lights on my air ratio gauge , but if I pull the plugs the only one that is the nice tan color I like to see it is the farthest from the throttle body I don't remember which clyinder that is but I thought it was suppose to be the one that runs a little richer than the rest so thats fine but the other plugs are really clean they dont look like there being super heated or anything but it scares me

my egt gauge has never read over 1270 ever I have seen as low as 900to1100 at full throttle before so according to both gauges I'm fine on fuel but I've never seen spark plugs clean when there running rich should I trust the gauges or can it still be leaning the other three cylinders out and be okay at the gauge .

any help would be greatly apprec.
 

·
Banned
Joined
·
0 Posts
Hard to say...I mean if your not getting any detenation and your egts seem normal. I don't think i'd worry about it.

But if you wanna go the extra mile go get a wideband 02 then you'll really know...
 

·
Registered
Joined
·
182 Posts
Discussion Starter · #3 ·
I had just never seen spark plugs clean when the engine was running rich. All the carburated motors I tuned always turned them light brown. I have the camshaft advanced could that be some of it ,I think it's 3* depending on how far the head has been milled I know it's been trued up but I'm not sure how far , is 140 psi compression on a fastburn normal, I'm not getting any detenation that I know of I havent heard it and every time I through the scanner on it it never says it has had to retard timming even when i'm watching going down the road
 

·
Registered
Joined
·
108 Posts
I had just never seen spark plugs clean when the engine was running rich. All the carburated motors I tuned always turned them light brown. I have the camshaft advanced could that be some of it ,I think it's 3* depending on how far the head has been milled I know it's been trued up but I'm not sure how far , is 140 psi compression on a fastburn normal, I'm not getting any detenation that I know of I havent heard it and every time I through the scanner on it it never says it has had to retard timming even when i'm watching going down the road
I had a car with bad timing (way retarded) give me 1400F-1500F EGT's at cruise, so your egts are probably OK. The 2.5 ecu is probably adding more fuel than a 2.2 needs which is probably helping your case. However, you may want to look into getting a calibration for your 2.5 that takes advantage of the T2 charge temp sensor since you now have an intercooler. I believe the T1 2.5L cars didn't use them (I'm sure someone will correct me if I'm wrong).

If you've got 250 or so to spare, get a wideband 02 and you won't have to guess how rich/lean you are.
 

·
Registered
Joined
·
182 Posts
Discussion Starter · #5 ·
NO the 2.5t1 doesn't have the charge air. I have been having fluxuation in how the car runs which seems to be a direct result to tempeture so that would probably help . like I said I was scared because of the clean spark plugs never seen that before. this is the first turbo car i've built so doing a lout of reading but sometimes. I just have to ask . next question with the egt i've got can I turn it up and not hurt anything as long as I don't go below 8lights and when should I stop on egts I have heard a lot of different things on temps?
 

·
Registered
Joined
·
108 Posts
NO the 2.5t1 doesn't have the charge air. I have been having fluxuation in how the car runs which seems to be a direct result to tempeture so that would probably help . like I said I was scared because of the clean spark plugs never seen that before. this is the first turbo car i've built so doing a lout of reading but sometimes. I just have to ask . next question with the egt i've got can I turn it up and not hurt anything as long as I don't go below 8lights and when should I stop on egts I have heard a lot of different things on temps?
Personally, I like to consider 1400F the limit under WOT. The car I mentioned earlier only ran for that way for a very short while until we fixed it. It's still together, so we obviously didn't do any permanent damage, but it was only a 20 minute highway cruise. I've heard ppl trapping the 1/4 with the egt's @ 1600 but I don't know how much of that an engine can take, and it's obviously not seeing prolonged exposures to that temp.

I personally more about the A/F ratio than the EGT's. If your A/F is good and solid, the egt's can be brought back down by increasing advance (which is somewhat counter-intuitive). I would just get a 3 bar setup and get your charge temp sensor wired in, that way you don't have to worry about fooling your current ecu and hoping it will put enough fuel in.

I'm sure someone else will jump in here and drop in their .02 about egt's, I'm eager to hear some other input too.
 

·
Registered
Joined
·
182 Posts
Discussion Starter · #7 ·
I have the cam advanced 5* will that make that big of a difference in how it runs I did that because I thought that was why it wasn't taking fuel but ounce I got in there I found it was retarded a tooth so I left the timing key in it thinking it wouldn't hurt me even though I had already corrected cam timing was that a bad idea
 
1 - 7 of 7 Posts
Top