Turbo Dodge Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4,611 Posts
Discussion Starter · #1 ·
any comments?

2.5 turbo, running 14 psi (peaked at 17 psi for a few dyno runs)

ECU thinks there is detonation

no audible detonation

running about 250whp / 300wtq @ 17 psi

there is some residual octane booster from a few tanks ago, i think thats why there is some reddish residue

these are autolite 63's with about 300 miles on them
 

Attachments

·
Registered
Joined
·
3,900 Posts
Heat range looks perfect. (see the electrode changing color midway down)
Top ring has nice color ... fueling is good.
Any speckles on the porcelain?
 

·
Registered
Joined
·
4,611 Posts
Discussion Starter · #3 ·
what would the speckles look like? there is nothing obvious..what you see in the pics is what they look like all around. are the speckles big? or is it more like microscopic speckles?
 

·
Registered
Joined
·
3,900 Posts
what would the speckles look like? there is nothing obvious..what you see in the pics is what they look like all around. are the speckles big? or is it more like microscopic speckles?
The eye can see them. Basically they are made up of bits of carbon (pepper) and aluminum (salt) after those periods of detonation. The detonation blasts them off the combustion chamber ... some stick to the porcelain so we can see them. From where I'm sitting they look good.

BTW I really like Autolites. I think the 63's do well in our engines.
 

·
Registered
Joined
·
4,611 Posts
Discussion Starter · #7 ·
exxon gas station near my house...91 octane, no additive, maybe some residue from octane booster a few tanks ago
 
1 - 7 of 7 Posts
Top