Turbo Dodge Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Can some one please help me.
I just got my first shadow es and when the car is at idle the engaine light turns on. . . I have noticed that when I turn the egnithion off then back on the light will turn off but then turns back on:confused: and when the light is on and I try to drive the engaine starts to surge : ( I have looked at the book and been into auto part stores and everyone tells me its the egr valve but I cant find the darn thing anywhere. Can anyone help?? please
 

·
Administrator
Joined
·
24,826 Posts
What year and engine?
Are you referring to the "Check Engine" light? If so the light is on because there is hard fault( happening now) and the vehicle is running on a fixed program failure mode.
You need to retrieve the fault codes before we can help you diagnoise the problem.
You can retrive the codes by :
Turn the ignition key, on/off, on/off, on
The "Check Engine Light" will begin to flash.
You have to count the flashes which will be code #'s
The code #'s are all 2 digits,the first flash's will be longer and slower indicating the first digit of a fault,the second flashes will be shorter and quicker indicating the second digit of the code and this will continue on until all faults are given and when you get code 55 that is the end of message and the controller is done communicating with you.
You may want to do it a few times to get used to counting the flashes.
Post back your results,you always start diagnostics with the lowest # code as 1 code may cause another to set.
Do not just throw parts at the problem.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Thank you : )
well its showing a code #13 but iv replaced all the air hoses and dubble check to make shure that there is no air leaks, I still does it : ( I have noticed that if im at a stop light and keep the rpm's at 2 it does just fine. is there something that im overlooking??
 

·
Administrator
Joined
·
24,826 Posts
Code 13 is MAP Sensor Pneumatic(Vacuum) circuit.
You will need a vacuum gauge. First check engine vacuum at a good manifold source and be sure you have 16-20 ". If not check engine mechanical and sealing.
If ok tee your vacuum gauge inline in front of the Baro Solenoid and be sure vacuum is reading the same as at manifold.If not check line for restrictions, loose connection of cracks/breaks. If ok...
Tee the vacuum gauge between the Baro Solenoid and Map Sensor.Is vacuum reading the same?
NO, Replace the Baro Solenoid
YES, Check Map Electical Connector for damage,looseness and corrosion. If ok..
Replace the MAP Sensor.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
Thank you sooo much!!! : ) I will do that. . once again, Thank you gus for your help : )
 

·
Registered
Joined
·
4,663 Posts
Your car does not have an egr valve btwy. If a turbo. Dunno about a tbi.
 
1 - 9 of 9 Posts
Top