Turbo Dodge Forums banner
1 - 13 of 13 Posts

· Premium Member
Joined
·
9,142 Posts
Discussion Starter · #1 ·
better cooling and maybe free up a little extra power !?

I have a couple ported out and cleaned up non-Common Block (non-CB ; that means '88 and earlier) water pump housings FS

ported like this:
http://www.turbododge.com/forums/f4/f15/161359-porting-water-pump-housing.html

very nice, ran thru my dishwasher so they're nice & clean

for an extra 6$ I will toss in a "known good" used water pump too !
 

· Premium Member
Joined
·
9,142 Posts
Discussion Starter · #4 ·
do u Have an L body one??? they are different.....

if so Ill take one!
I have a couple but they are all the same ; heater hose exits straight out...

doesnt the L version come off at an angle or ?? how R they different ?

one of them came off an 87 SC so it may have been incorrect but still worked fine; and I'm pretty sure i have a straight outlet on my 86 TII omni ..
 

· Premium Member
Joined
·
9,142 Posts
Discussion Starter · #7 ·
yeah it has some retarded angle too it lol....I have all the proper L body hoses and stuff so I kinda dont want to switch it over...
can you PM me with a link to a pic so I can see the difference ?

if I have one on my omni I'll pull it and port it 4 ya ; my omni's a mutt so I dont care if it has the correct WP housing .. and I KNOW it doesnt have the correct Lbody hoses... %)
 

· Premium Member
Joined
·
9,142 Posts
Discussion Starter · #9 ·
No CB ones? shoot...
I do have one CB housing (on my future engine once my 85 TI shortblock grenades) which I guess I will let go for 20$ ported and cleaned up nice; PM me if interested

once the snow melts ( usually mid june ;) ) then I can get to my local junkyard and see what is available for spares.. I know they are holding a couple LMs for me

if anyone else needs a CB housing LMK and I'll see what I can do
 

· Premium Member
Joined
·
9,142 Posts
Discussion Starter · #10 ·
do u Have an L body one??? they are different.....

if so Ill take one!
OK so the one I pulled off my 86 Omni has NO heater hose outlet ; is that an "L-body" housing ?

if you want it PM me ; today I ported it, sandblasted it, washed it, then threw 2 coats of clear lacquer on the outside ; looks nice!

I plan to rig up a "#4 cylinder" cooling loop and will use a different housing; (all the others have a heater hose nipple pointing "straight out back")

PS I've got a couple more left !
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top