Turbo Dodge Forums banner

1 - 20 of 60 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
Hi all! Fairly new here. Got an 87 Shelby Z and well its not starting and I donno why.

The car just wont start.

apparently this is a common problem. It turns over, but doesnt fire.
I dont have 12v to the coil or the fuel pump, and therefore I have no fuel or spark.
I replaced the pickup coil. no go.
I replaced the power module. no go.
I cleared the computer and got the engine codes. 12 then 55.

so I dont know where to go from here. I guess a fuseable link is probably bad, does anyone have an idea WHICH it may be, or any other ideas. I guess the logic module could be bad?

The car sat for a long time, the lady i bought it from said the last time she started it was september, and then a month later she tried to take it for one last drive for the winter but it just wouldnt start up. She was sick of sinking money into it so she sold it to me for $475.

Just for good measure I changed the oil, plugs, wire, cap, rotor, coil, fuel filter, and oil filter, but one of the spark plugs snapped and is stuck in the head now. :bang head

I could probably get the plug out if I pull the head off, but I am going to the junk yard on Saturday anyways, and I think it wouldnt be a bad idea to pick one up. what heads are interchangable with the 87 shelby Z head? and how much time should it take to swap the heads?

Anyways, enough babbling gotta keep checking stuff.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #3
yes i did. I also replaced the spark time delay relay, all the fuses are good in the fuse box (not that they should be making much difference, but either way those are all good)
 

·
Registered
Joined
·
2,122 Posts
can you hear the fuel pump prime when you turn the key on?
I had a spark plug stuck in an engine I got that had been sitting for years. I put a breaker bar on it with a pipe and it busted free.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #6
its an autoparts one that was new and came with the car (new distributor from advance or auto zone). I have a mopar one being shipped to a dealer though b/c i heard the advance ones are crap.

Is the distributor from advance ok to use or should I get the mopar distributor as well?

I am getting no power to the fuel pump. I cant hear it click on, and I checked and it is getting nothing.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #7
and the socket part of the plug snapped so its flush with the head. the only thing left is the ceramic and threads. the center blew out when i cranked it (I figured it should still start or at least fire even if its only 3 cylinders)
 

·
Registered
Joined
·
287 Posts
There are 2 wire connectors on the logic module. It is not uncommon for moisture to get in them and corrode the contacts. Take them apart and spray them with a good electrical cleaner and put them back together and try again. CRC QD Electronic Cleaner is what I use. It's great stuff and won't damage plastic.
Frank H.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #9
There are 2 wire connectors on the logic module. It is not uncommon for moisture to get in them and corrode the contacts. Take them apart and spray them with a good electrical cleaner and put them back together and try again. CRC QD Electronic Cleaner is what I use. It's great stuff and won't damage plastic.
Frank H.
Ill try that tomorrow. Ive had 2 nights in a row if working on car related projects til 4am and I get up for work at 5:30 so i need to catchup on some sleep. Any other Ideas people have i will try. I know I probably should have just tried the mopar Hall effect, but I figured this one would last at least ONE drive.

Thanks guys, Im glad I found this forum :)
 

·
Registered
Joined
·
297 Posts
Ill try that tomorrow. Ive had 2 nights in a row if working on car related projects til 4am and I get up for work at 5:30 so i need to catchup on some sleep. Any other Ideas people have i will try. I know I probably should have just tried the mopar Hall effect, but I figured this one would last at least ONE drive.

Thanks guys, Im glad I found this forum :)
Auto parts store distributor is probably fine but I would not trust the pick-up. The one time that I tried one from an auto parts store it was bad from the box.
 

·
Registered
Joined
·
2,394 Posts
You should be able to hear the fuel pump kick on for a second regardless of the hep. check those fusible links near the battery the squirrels just love to chew on them.
As for the plug you could try drilling it out a little thinner to make it easier to get out and then put an easy out in there or just drill it all the way out and put in a helicoil or spark plug repair kit, a shopvac works good to help keep the metal shavings to a minumum.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #14
i had that problem. the lm was sending a bad signal to the hall effect pickup.
Goig along with that idea, Is there a way to check that signal? after looking over the diagrams it appears as though It is either the tan/yellow wire or the grey wire that sends a signal to the hall effect. what kind of signal should I be looking for out of there?
 

·
Registered
Joined
·
1,017 Posts
Goig along with that idea, Is there a way to check that signal? after looking over the diagrams it appears as though It is either the tan/yellow wire or the grey wire that sends a signal to the hall effect. what kind of signal should I be looking for out of there?
my dads got a shop, and hes got a snap on tool that has a volt reader and a bunch of stuff like that. so i took the tool and put the prongs into the wire entrances on the lm that went to the hall effect. theres suppose to be 2 5 volt signals but it was sending an 8.5 volt signal and the line was really thick, probably covered a 3 volt range, when i got the new lm in it was a really thin line straight across 5 volts. where did you get the lm from and whats the stage etc etc.. i might be able to fax you a diagram for the lm connection diagram.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #17
It is original to the car as far as I know. I measured the volts coming out of the plugs that plug into the hall effect and they are:

Image uploading. Refresh page to view
 

·
Registered
Joined
·
1,017 Posts
It is original to the car as far as I know. I measured the volts coming out of the plugs that plug into the hall effect and they are:

Image uploading. Refresh page to view
to my knowlege both of those are suppose to be 5 volts. ill look at my lm diagram when i get home from work tonight if i remember.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #19
I got some parts from the junkyard, and im gonna replace them and see what happens.

I lost the keys though.... :bang head

I dont know where they went, but Ill let you know what I find out.
 

·
We'll do it live!
Joined
·
7,614 Posts
Man you are having no luck with your shelby. Any luck at all with the starting?

btw couldn't help but notice you're from cincinnati.
 
1 - 20 of 60 Posts
Top