Turbo Dodge Forums banner
1 - 8 of 8 Posts

· Registered
Joined
·
117 Posts
Discussion Starter · #1 ·
I had my 86 Shelby Charger out today and everything was going great till I tried to shift from third to forth. The shifter just went limp and the car was in neutral. I coasted to a red light. I was able to put the car in first gear. When the light turned green I took off from the light and when I went to shift to second all I got was neutral. I was able to pull into a repair shop I have used. That's where the car sits now. Can anyone tell me what broke and is this going to cost me alot. I tried to search this but did not find much. Any help will be much appreciated.

Dennis
 

· Mr. Moderator
Joined
·
8,952 Posts
^same thing happened to us. On my way to basketball practice got stuck in fourth gear!
We hit a light on the hill and had to get out and push it to get it going enough to keep going in fourth LMAO. Our car sat for 6 years after that!
That bushing is not easy to find!
We had a friend of ours lone us one and we found 3 others through a dealership part locator and shipped 2 outa texas and one out of newyork!
Not a hard fix its just locating the part
 

· Registered
Joined
·
186 Posts
Ya, these rod shifters are crap. I shortened my throws, replaced bushings and rod ends, and adjusted the mechanism, and it still shifts like 30 year old Vietnamese rickshaw (if they had shifters!).

Don't worry, it's not an expesive fix at all, just an irritating one. Not an internal failure or anything, just the external mechanism.
 

· Mr. Moderator
Joined
·
8,952 Posts
^ we tightened everything up and the GLHS shifts better than new!
Modded the linkage, replaced all bushings, used different bolts, adjusted the linkage and its tight as hell now!
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top