Turbo Dodge Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
203 Posts
Discussion Starter #1
Hey I was reading a post from shelbysawn and got to thinking, I dont really know what exactly is the SMEC does or I didnt understande what the manual said, but I had converted to T2, and installed a MP GLHS stage two LM and I still cant run any more than 8-10 psi of boost and the specs are 12psi [email protected], I have auto meter air fuel gauge, but havnt really hooked it up right, have tried three diferent map sensors(one with Zener Diode from old T1) cheacked out the tps it tested ok, pump is good, fuel presure is good(little on the high side4-5 psi) I thought it was ok, its acually R/T fuel regulator. I have tried several fuel presure set ups none better than this one. the problem is when I run more than 10 psi the car just starts bucking and its not like over boost cut out iether, I have acually got it up to like 18 psi fethering the gas lightly I think 18 is overboost, what could it be, could it be the SMEC or somthing else I am open to sugestions and ideas I have been working on this problem for a couple of monthes.. Sorry for the Novel I didnt wanna leave anything out, thanx Drew
 

·
Registered
Joined
·
2,125 Posts
Well the SMEC is the computer, but that only came on later cars. 88-89 I believe. You are running the LM computer so you dont even have an SMEC on your car. Did you add the later model TB with the 4 wire TPS and the extra wires to the LM? If you didn't that would definitally cause your problem as the LM isn't getting the right signal from the TPS. If you did are you getting any codes? I had a very similar problem on my TII conversion and it turned out that I have a bad connector on my TPS.
 

·
Registered
Joined
·
72 Posts
I just picked up the computer along with all the wiring of an 88 car.
Do I just over ride the LM if I hook this computer up.
I noticed I didn't get the Air Charge Temp connector. What are the pin outs to the computer for this sensor?
 

·
Registered
Joined
·
72 Posts
Well I was just reading thru the Minimopar site and found out that I picked up the TI computer with no Air Charge Temp to pin 21.
The car was not intercooled. Man that sucks. Can I still install the wiring and later upgrade to the TII computer and just run the wire to the 21 pin?
 

·
Registered
Joined
·
2,125 Posts
If you have the comp. reprogrammed to recognize the air temp sensor all you have to do is run the wire. So if I was you I'd just run it for now until you can get a custom calibration. Or if you want get a TII computer and run the wire. Actually if I remember right the wire is already there on the TI harness, just not hooked up.
 

·
Registered
Joined
·
72 Posts
Correct the wire is there. I'll just leave the sensor and wiring for a later time when I add the IC.
Has anyone ever done this conversion on an 84 Daytona?
If so what wires do I need to keep to run the 88 computer?
I noticed on the new computer there are wires going to it from the cruise control where as on the old setup these two where completely seperate circuits?
 

·
Registered
Joined
·
2,125 Posts
Maybe shoot a pm to swifttech, I think he converted his 84 daytona over to later electronics.
 

·
Registered
Joined
·
72 Posts
Well I did it I converted my 84 Daytona this weekend to 88 SMEC.
Still have a few connections to figure out but the car is running.
The things I need to figure out are:

1) A/C won't turn on
2) No brake lights
3) Need to run wire for Power Loss lamp in order to read any codes.
4) Need to re-run vacume lines for new relays (MAP, Purge, Waste Gate...)
5) Figure out why it falls on it's face right before boost..

Any help on any of these would be greatly appreciated.
 
1 - 11 of 11 Posts
Top