Turbo Dodge Forums banner
1 - 20 of 35 Posts

· Registered
Joined
·
1,556 Posts
Discussion Starter · #1 ·
so i just swapped the 525 out of my omni for a 555. bolted everything up and it went fairly smooth. used a t3 pressure plate and my stock clutch. well i went to put the starter on and it seemed to fit. went to start it and it just clicks. like it's engaging but not tuning over the engine. so i decided to try and turn the engine over myself by the crank pulley. well it's like it gets stuck. like the transmission is holding it back or making it get stuck. yes it is out of gear. so i don't know what the **** is going on. anyone have any idea? i really don't feel like taking the trans out again. i'd sell the ****ing car before i do it again.:bash: i have spent the last 3 months putting this car together and i'm just a little fed up with the mother****er.
 

· Registered
Joined
·
4,833 Posts
What condition of the trans prior to installation? Is the trans really holding the engine solid, such as is it still in gear even though it should be out? When you step on the clutch, does the engine try and start, such that it is the trans and not something wrong with the clutch? I would just start going from there. It took an engine blowing up before I went to the "salvage" idea with my car. But now I have a new one, so. The best of luck.
 

· Registered
Joined
·
1,556 Posts
Discussion Starter · #6 ·
What condition of the trans prior to installation? Is the trans really holding the engine solid, such as is it still in gear even though it should be out? When you step on the clutch, does the engine try and start, such that it is the trans and not something wrong with the clutch? I would just start going from there. It took an engine blowing up before I went to the "salvage" idea with my car. But now I have a new one, so. The best of luck.
well i haven't changed the positioner thing and the adjuster on the back of the pedal yet. so i can't step on the clutch. i haven't filled the trans with fluid yet either. the trans seemed to be in good shape before install. i bought it from a guy from kansas.
 

· Registered
Joined
·
4,833 Posts
NOT ME, I SWEAR. LOL, well, hmm. I would go and attach the clutch before I would start looking at scrapping the car. I don't know if you could have the whole thing kinda jarred in there so it does not want to turn period, and releasing the clutch may help with it. Or you may find what the problem is. That and I would make sure that the car is in neutral as well. Lift the front up and see how the tires respond. If they are pretty solid and the car is in neutral, then I would say it isn't. But I am thinking that is right. I am getting tired, and my memory is starting to get fuzzy. LOL.
 

· Registered
Joined
·
1,556 Posts
Discussion Starter · #8 ·
NOT ME, I SWEAR. LOL, well, hmm. I would go and attach the clutch before I would start looking at scrapping the car. I don't know if you could have the whole thing kinda jarred in there so it does not want to turn period, and releasing the clutch may help with it. Or you may find what the problem is. That and I would make sure that the car is in neutral as well. Lift the front up and see how the tires respond. If they are pretty solid and the car is in neutral, then I would say it isn't. But I am thinking that is right. I am getting tired, and my memory is starting to get fuzzy. LOL.
i have the car jacked up still and both sides seem to turn freely. i might have to lift up on the clutch fork thing and see if its pretty free or not. i assume you can move it by hand right?
 

· Registered
Joined
·
13,677 Posts
dont do it by hand, when it lets go it hurts LOL, use a jack. if it isnt right youll start lifting the car and not the arm.

Curtis is suppose to call me this weekend, if he does ill be in Tulsa. LMK if you can use a hand and ill bring those wheels and we can load up that shortblac(btw did you find out if it was TI or TII? the rods are my worry lol).
 

· Registered
Joined
·
4,833 Posts
If you are talking about the clutch fork, you are a stronger man then I. Hell, I weight about 175, but I could barely move it in my poor ole Rampage. Moving it to where it is fully dis-engaged and the clutch is free. I would do it with a jack like Clayton said. But the arms should move freely, if it does not, I would say your clutch may be part of the problem. But that would be one of the first places I would start at to start eliminating possibilities.
 

· Registered
Joined
·
1,556 Posts
Discussion Starter · #11 ·
If you are talking about the clutch fork, you are a stronger man then I. Hell, I weight about 175, but I could barely move it in my poor ole Rampage. Moving it to where it is fully dis-engaged and the clutch is free. I would do it with a jack like Clayton said. But the arms should move freely, if it does not, I would say your clutch may be part of the problem. But that would be one of the first places I would start at to start eliminating possibilities.
yea i moved it by hand. it's pretty stout. i changed the clutch position thingy and it didn't change a thing when i tried to crank it with the clutch pedal down. sounds as if there is something jammed in between the block and flywheel or something like that. because i can move the crank like a little bit one way and it stops then back the other way then it stops. i tried moving it one way,getting in the car and trying a start thinking maybe it will loosen whatever is blocking it but nothing works. it gets to that point and jams up. like i said i really don't feel like dropping a trans again. if so i'm doing it with a cherry picker this time. or selling the damn thing and getting a turbo van or something. no more incredible hulk lifting tranny from under hood by hand bull shit.
 

· Registered
Joined
·
1,556 Posts
Discussion Starter · #12 ·
dont do it by hand, when it lets go it hurts LOL, use a jack. if it isnt right youll start lifting the car and not the arm.

Curtis is suppose to call me this weekend, if he does ill be in Tulsa. LMK if you can use a hand and ill bring those wheels and we can load up that shortblac(btw did you find out if it was TI or TII? the rods are my worry lol).
word will do. no i haven't found out what block it is. block number is 4343834-6
 

· Registered
Joined
·
4,833 Posts
well, it sounds like you may have found what the problem may be. You will probably have to pull the engine to see what the problem is from there. It may suck, but that is probably the best way to go about it.
 

· Registered
Joined
·
4,660 Posts
no more incredible hulk lifting tranny from under hood by hand bull shit.
amen to that, what I have done is place a 2x4 across the fenders and place a winch to pull the transaxle up. Also make some guide pins with some bolts and screw them into the top 2 holes. To make the pins cut the heads off 2 bolts, cut a slot on the tops so you can screw them in and out and grind the threads to dull them where the tranny is going to slide so it does not cut into the soft AL case and make it bind.
 

· Registered
Joined
·
1,571 Posts
Don't give up.

Whenever I get to point where I just want to quit, I think about the guy who swam the English channel. He made to about 50 feet from France, but he was so tired that he turned around and swam back.
 

· Helping when I can
Joined
·
1,327 Posts
Don't give up.

Whenever I get to point where I just want to quit, I think about the guy who swam the English channel. He made to about 50 feet from France, but he was so tired that he turned around and swam back.
now thats funny!

+1 hang in there!
 

· Registered
Joined
·
1,571 Posts
So now it's back under my car for me too. I just cracked the tranny case last night at the track.
 

· Registered
Joined
·
1,556 Posts
Discussion Starter · #20 ·
You probably put the clutch disc in backwards or didn't get the splines lined up and forced the trans onto the motor so everything is bound up tight as all hell.
i'm pretty sure my clutch disc isn't in backwards.it also wouldn't prevent the motor from being turned over. the trans went in smooth and was not forced in. i think maybe either the pressure plate maybe too big for the bell housing or a bolt or some shit fell and is stuck between the bell housing and flywheel or pressure plate. :mad:
 
1 - 20 of 35 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top