Turbo Dodge Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
i have a problem, my speedo was working but stopped now, it was an analog so i switch to digital now, evrything is hookled up correctly, speedo still doesnt wrk, where is the speed sensor located, mayb its bad
 

·
Super Moderator
Joined
·
11,857 Posts
It's on the little axle shaft housing on the passenger side of the diff

you should be able to see it , from above ,down behind the motor where the starter is
 

·
Registered
Joined
·
66 Posts
Speed sensor does NOT provide input to the speedometer, just to the computer. Speedometer is driven by cable that the speed sensor is mounted on.
 

·
Premium Member
Joined
·
4,343 Posts
Yeah, 86 is actually the last year for cable speedos. They are the ones with 125mph to upgrade 84-85 cars. 87 was first elect only speedo.- and early(84-85?) digital cars.(did 84s have digitals? my 85 does)
 

·
Registered
Joined
·
330 Posts
is it the same set up as my 90 shadow? theres a tsb on fualty connectors on the distance sensor if its like my car. dont know if that helps.
 

·
Registered
Joined
·
991 Posts
My 86 daytona has a digital dash but it is cable in the tranny! What is the unit in the transmission called and where can I get one?
 

·
Premium Member
Joined
·
6,975 Posts
speed/distance sensor. i'll post up the factory mopar part # tomorrow so everyone can source a new one from mopar, they are still available.
 

·
Registered
Joined
·
491 Posts
Can someone post a picture of a correctly plugged in one. I don't think mine is all the way in because my speedometer is bouncing back and forth under acceleration. Thanks
 
1 - 11 of 11 Posts
Top