Turbo Dodge Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
809 Posts
Discussion Starter #1
Not the best times- 14.375 @97.72. My boost was only holding 10PSI but would spike to 14PSI. I am putting in that G-valve and setting it for 16PSI this weekend so I can be done with the boost changing everytime I drive the car. I was expecting 13.6-13.8 seconds but I guess if I had the boost I was expecting I would have been right there. 60' was 2.246 and I was using drag radials but I did not heat them up. Kind of dissapointed but I am close.
 

·
Registered
Joined
·
519 Posts
with an all stock r/t except exhaust and 50HP shot of nitrous my car ran a [email protected] with slipping clutch in 3rd and 4th and spinning takeing off with a 2.3 60ft time so just get some nirous :thumb: i love nitous :D
 

·
Registered
Joined
·
809 Posts
Discussion Starter #3
before I do anything like nitrous I want to get all the bugs worked out and max out what I have then I will look at new things to do. Right now I am at about the stock times for an R/T but I guess that is to be expected with the low boost. I am really hoping to shave off half a second this weekend :).
 

·
Registered
Joined
·
519 Posts
i was running drag radial too i wish i would of spent the money and got real tires they help alot but i still spin, we both need to work on our 60 ft times if you cut a 2.0 that would put you about a 13.9 range
 

·
Registered
Joined
·
809 Posts
Discussion Starter #5
Going to the drag strip in the morning to give it another try. Installed G-valve and am holding 15PSI steady. Also filled the motor mounts with eurothane and modified the rear bobble strut by putting a SBC valve spring to make it stiffer and shorten the travel of the motor( thanks Wallace). Also installed air shocks on rear. I am not going to use the drag radials this time but am going to use the goodyear F1's that I have for street tires.
 

·
Registered
Joined
·
809 Posts
Discussion Starter #10
Just got back a little while ago. Not really satisfied with the times- my best was 14.276 @ 96.78MPH. Had some really bad launches but on this run I had a 2.210 60' time. My boost was acting up again- holding 12 and spiking to 14. Thought with the G-valve it would hold steady boost no matter what after I had it set to the PSI I wanted? I adjusted my fuel pressure up and down a few pounds but no noticable difference. Am I missing a piece of the puzzle to get mid 13's? Or is my launch just that bad? Next time I am taking the drag radials and getting them nice and hot. This car has just had the head done,titanium retainers,mild porting,FWD stage 1 ECU,+20 injectors,aftermarket BOV set at 20PSI, adjustable fuel regulator, full 3" exhaust with no cat and dynomax muffler, and my target boost is 15PSI. Any ideas what I am overlooking or what I am doing wrong? Thanks
 

·
Registered
Joined
·
683 Posts
darktone said:
Just got back a little while ago. Not really satisfied with the times- my best was 14.276 @ 96.78MPH. Had some really bad launches but on this run I had a 2.210 60' time. My boost was acting up again- holding 12 and spiking to 14. Thought with the G-valve it would hold steady boost no matter what after I had it set to the PSI I wanted? I adjusted my fuel pressure up and down a few pounds but no noticable difference. Am I missing a piece of the puzzle to get mid 13's? Or is my launch just that bad? Next time I am taking the drag radials and getting them nice and hot. This car has just had the head done,titanium retainers,mild porting,FWD stage 1 ECU,+20 injectors,aftermarket BOV set at 20PSI, adjustable fuel regulator, full 3" exhaust with no cat and dynomax muffler, and my target boost is 15PSI. Any ideas what I am overlooking or what I am doing wrong? Thanks
Where did you tap in the Grainger? If it's on a barb from the turbo it'll spike. Best place to hook it up is on the intake manifold with as short a line to the actuator as possible. Also, you may want to get a pair of slicks instead of DR's and balance the load across the front end.
 

·
Registered
Joined
·
809 Posts
Discussion Starter #12
I ran the G-valve off the same port as the map sensor and ran the line as short as I could and have the G-valve as close to the turbo as I can and still get to it for adjusting. I will get slicks one of these days but I still feel like I am half a second slower than I should be without them.
 
1 - 12 of 12 Posts
Top