Turbo Dodge Forums banner
1 - 9 of 9 Posts

· Registered
Joined
·
744 Posts
Discussion Starter · #1 ·
I get some grind when shifting so I bought the shift fork pads and have the trans dang near ready to pull but as I was taking off my cables I noticed one of the cable end grommets that slips over the trans brackets is pratically gone. There is at least 1/2 inch of play there..would this make the gears grind??? 1 to 2nd is okay but I skip 3rd and shift right to fourth and going into 5th is alright. Its a 568 trans.
 

· Administrator
Joined
·
26,461 Posts
Yes the snap grommets on the shifter cable are a common problem, you can replace the grommets with poly bushings or replace the cables.
 

· Registered
Joined
·
744 Posts
Discussion Starter · #6 ·
Well I got it apart. The synchros look okay but shift fork gears have light burrs on them as well as some of the other gears. I dont know manuals very well..can these be cleaned up with a file or what?? The input gears look great. Also anyone know of a site where I can get a assembly procedure? I could probably do it without it but have something to reference is always nice!!
Next question. If I go with a 555 will the clutch and axles work? I know I will need another shifter and cables...what about the 523 or 520 trans??
 

· Registered
Joined
·
744 Posts
Discussion Starter · #8 ·
I picked up a 523 but need HEAVY duty unit so may return it. I pm'd a fellow TD'er about a 555 setup so we'll see. I would like to find transaxle repair manual or its like. The car is GLH-S #711, BUILT T2 ((18psi)).
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top