Turbo Dodge Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
My 2.2 shelby is vibrating so much right now and its very annoying. What could cause this? I originally thought that it was due to my timing belt but im not so sure anymore. I changed that. i also changed the motor mount at about the same time. could that cause anything like that? ANY AND ALL HELP NEEDED
 

·
Administrator
Joined
·
24,830 Posts
Where is the vibration felt?
Is the engine actually running poorly?
Do you feel it in the steering wheel,brake pedal or thru the body?
At what speeds or conditions is it most prevalent?
 

·
Registered
Joined
·
34 Posts
Discussion Starter #3
im not quite sure how the motors running, seems normal enough to me. But i could be wrong. i feel the vibrations through the entire car. The whole dash shakes, the rear shakes. Its like everything is shaking
 

·
Administrator
Joined
·
24,830 Posts
At all speeds and at idle?
 

·
Administrator
Joined
·
24,830 Posts
If the vibration is that severe with the vehicle not moving it is engine/engine mount/trans related.Since this is a Shelby I am assuming it is a manual trans.
My next question is was anything done to the vehicle or did anything happen prior to the vibration appearing?
Are there any noises that have suddenly appeared with the vibration?
 

·
Registered
Joined
·
34 Posts
Discussion Starter #7
no sudden noises, and the only thing done prior to the vibrations was change of oil and fixing the motor mount
 

·
Administrator
Joined
·
24,830 Posts
Sorry for all the questions but this is the only way I can narrow down where the problem is originating from.
First you have to determine that the engine is running on all 4 cylinders and is running smoothly.Did you replace the timing belt or you were just thinking it may be that?
You replaced the R/S engine mount,did you replace just the insulator or the entire mount/bracket assembly?
 

·
Administrator
Joined
·
24,830 Posts
That sounds like a good plan, you should take him up on the offer.
I asked about the mount because the times I destroyed mine it was hard launch's and shifting at the track and it totally bent the bracket assembly and the engine was down and back on the R/S. The drive axle was actually hitting the engine.
But the way you are describing the vibration especially at idle it sounds as though the engine is not running correctly.
 
1 - 13 of 13 Posts
Top