Turbo Dodge Forums banner

1 - 20 of 26 Posts

·
Registered
Joined
·
226 Posts
Discussion Starter #1
well i asked a buddy to give me a hand tonight with my 92 iroc rt
was going to look into why my cel light doesnt seem to light up. ever.. lol
well my buddy pulled a stellar move in his rush to figure it out and hooked up the batt backwards. :bang head
so now i have a car that has a coolant temp guage thats maxed out all the time, a batt guage that doesn't want to work at all, no headlights, drl's seemed to work, if i remember right might just have been the drivers side tho. car runs rougher than i remember, and while driving her to the back yard she wanted to stall out when i put the clutch in.

so i just told my supposed electrical wizzard of a buddy to go home and ill hopefully figure it out with the help of the pros here so here we go again.
thanks in advance. :bang head
 

·
Administrator
Joined
·
24,135 Posts
I can get back with you in further detail tonight but in the meantime check ALL fuses in the underhood PDC and Interior Fuse Block for power in and power out.
 

·
Registered
Joined
·
226 Posts
Discussion Starter #3
all fuses in the pdc checked out. power in and out of all fuses in the car except the 4 10A fuses that control lights no power at all to these 4 im assuming its a relay, does that pannel under the dash move somehow to maybe drop down for testing purposes?
 

·
Administrator
Joined
·
24,135 Posts
Fuses for exterior lamps will not have power unless the lights are turned on.
Is this how they were tested?
 

·
Registered
Joined
·
226 Posts
Discussion Starter #7
ill have to get to the car after work. the other night i had no lights at all for the first half block as i moved the car to the alley to store it for the winter when my drivers side drl came on. but no real headlights or fog lights.
hazards and signals work tho. lol
 

·
Administrator
Joined
·
24,135 Posts
Power to fuses 17, 18, 19, 20(L/S and R/S low and High Beam)comes from the Low and High Beam Relays.
The Headlamp Switch controls the ground side of the Relays.
Here is where we are going to start, you will need to post back where it leads so I can post the next sequence in the diagnostic flow chart.



 

·
Administrator
Joined
·
24,135 Posts
I am not home on the weekend so if you post early enough I can get you the next step in the diagnostic sequence.
 

·
Registered
Joined
·
226 Posts
Discussion Starter #17
yeah i hear ya. lol. i got no experience so thats making it a pain. lol thought i had her beat yesterday but i messed up along the way i guess. thought the diagnostics led me to change the switches. did that and something let a little puff of smoke out again. funny thing is i had the relay in my hand at the time. starting to feel like i should just give up. lol.
guess ill have to find another set of switches and start the proces all over again. booo. lol
really need to get a handle on this electrical soon tho. lol.
 

·
Registered
Joined
·
226 Posts
Discussion Starter #18
Hey Naj
Was looking at this again and it appears i have daytime running lights and only get parking lights when i try to turn on headlights
I have a buddy coming over to help this wk and was wondering, if he comes to the conclusion its the switch how would i bypass it as i do not have another at this point in time
Thc
CS
Just checked the orange wire with white tracer and it has 11.76 v at the conector for the switch
 

·
Administrator
Joined
·
24,135 Posts
The BCM controls the ground side of the relays when it see's a signal from the headlamp switch to turn the lights on.
To Start...
1)Locate the low beam relay and see what is present on the OR/WT wire at the relay with the headlamp switch off and then on.
2)Be sure you have continuity to ground on the BK/OR wire at the dash harness side of the headlamp connector
 

·
Registered
Joined
·
226 Posts
Discussion Starter #20
Relays removed
Lights off 9.10v
Lights on 8.87 v

Test 2
Black electrode put to spot by drivers left foot where 5 other wires ground to body pulled instruments pod so i can check black wire w/ orange tracer
Reading is .437

Also noted when i turn on lights the one relay to the right (by itself now) clicks is this normal? Im assuming its normal as its not crazy loud
 
1 - 20 of 26 Posts
Top