Turbo Dodge Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter #1
recently got my turbo rebuilt, and got it all put together (reused cometic headgasket with copper spray and arps) and i took it for a ride and it seems to drive fine but it smokes out the tail pipe im fed up of this thing not running right anyone have any advice? ps. compression test was good

thanks mike
 

·
Registered
Joined
·
80 Posts
Discussion Starter #2
So I'm thinking maybe the white smoke is coming from when the turbo went and left oil in the downpipe, I'll take it for a long ride to see if it gets better. I also hooked a catchcan up how is everyone running there pcv with a catch can?
 

·
Registered
Joined
·
80 Posts
Discussion Starter #4
It smokes at idle and when moving slow, didn't notice any smoke at wot, I don't have pictures of the pcv its hooked up like this: from intake to pcv valve to air box
 

·
Registered
Joined
·
12 Posts
i had the same problem(plus smoke at wot) when i had a hybrid turbo made at turbonetics in 2004. I had to send it back, for the shaft seals. :bang head
 

·
Registered
Joined
·
80 Posts
Discussion Starter #9
theres no cat on the vehicle, cleaned downpipe out with engine degreeser(sp) and water, no shaft play, no signs of oil at throttlebody or intercooler... anything else?:bang head
 

·
Registered
Joined
·
80 Posts
Discussion Starter #10
was just driving it and its still smoking and only boosting to 6 psi, and i blew out a freeze out plug..... whats going on
 

·
Registered
Joined
·
12 Posts
Check your coolant level. If it is going down the head gasket may be leaking internally and the engine is burning the antifreeze, making white smoke.
 

·
Registered
Joined
·
39 Posts
Hi I had almost the same problem a few weeks ago (white smoke out from the tailpipe), and I found the the injector #1 had a faulty contact on its connector, the engine even ran better (no smoke) by disconnecting the injector , then I cleaned the connector and it had ran fine up to date.

In the beginning I thought it was a bigger problem, but when I moved the tubes and wires around the injectors area, I found about the faulty contact.
 

·
Registered
Joined
·
80 Posts
Discussion Starter #15
so i have to take the head off to replace the freeze out plug, so while its off im gonna put new exhaust side valve guides, and valve seals. im gonna be reusing my cometic headgasket, should i just spray the hg with a good coating of copper spray before i reinstall it??
 

·
Registered
Joined
·
543 Posts
Sounds like you are persurizing the coolant system due to the head gasket leaking. Did you check the deck of the block for flatness? was the cometic new when you installed it? When I reuse a cometic I dill the rivets out, clean each layer, spray each layer with permatex spray-a-gasket, and reinstall.

Adam
 

·
Registered
Joined
·
328 Posts
seems like there is pressure build up in the cooling system and it blew the frost plug out, possibly due to leaks at the headgasket under boost, I have seen many diesel trucks that pressurized the cooling system only when pushing high boost, they come from the factory with MLS gaskets so they can still fail
 
1 - 17 of 17 Posts
Top