Turbo Dodge Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
670 Posts
Discussion Starter #1
I need to get one of the short 525 linkage rods with the black bushing in good shape, ready to install on my 1986 Omni. Below is mine, without the black bushing in the large end, the bushing fell apart. Note: There are two types of these bars. This style is found on the N/A L-body cars with 525, this rod is straight and configured as seen in photo. Let me know if you got one. I'm sure they are out there. Thanks in advance!
 

·
Registered
Joined
·
670 Posts
Discussion Starter #3
I hear those kits of yours are awesome! However, I am just looking for this one stock style piece. Thanks for the reply!
 

·
Registered
Joined
·
670 Posts
Discussion Starter #4
I know somebody has one of these.
 

·
Premium Member
Joined
·
1,157 Posts
I'll look tomorrow and see if I have the black insert.
They typically fall out and once it does, it doesn't stay put.
Chrysler made a clip to hold the rod to the lever. You may be able to find one on the forum.
The clips don't really stay too well either.
 

·
Boost is a good thing!!
Joined
·
1,008 Posts
The big C-clips we actually called "The Mopar Shift Improver Kit". The clips came standard on all 88 and up Horizons and Omnis that were 5 speed.

Somebody tell me different, but I heard the ends of these rods can actually use the wiper bushings when those inserts break? But what "turbododge" wanted was the black bushings, so I dont know.
 

·
Premium Member
Joined
·
5,951 Posts
which rod is that one as the only one that had a round eyebolt bushing like that was in the main shift rod coming off the shifter
 

·
Registered
Joined
·
670 Posts
Discussion Starter #9
Absolutely. This is part of the N/A 525 equipped 1986 Omni linkage. And to clarify, I need a rod with the bushing still in it. If you got one out of a rod, you will have boogered one of the shoulders to get it out. They don't come out/go in without compromising them. Thanks for all the replies!
 

·
Premium Member
Joined
·
5,951 Posts
Must be different shiftrods as that doesn't look like anything on my turismo
 

·
Registered
Joined
·
670 Posts
Discussion Starter #11
Anybody have an N/A omni with this shifter linkage and black bushing still intact?
 

·
Registered
Joined
·
670 Posts
Discussion Starter #12
bump
 
1 - 12 of 12 Posts
Top